728x90
문제
두 자연수 A와 B가 주어진다. 이때, A+B, A-B, A*B, A/B(몫), A%B(나머지)를 출력하는 프로그램을 작성하시오.
입력
두 자연수 A와 B가 주어진다. (1 ≤ A, B ≤ 10,000)
출력
첫째 줄에 A+B, 둘째 줄에 A-B, 셋째 줄에 A*B, 넷째 줄에 A/B, 다섯째 줄에 A%B를 출력한다.
예제 입력1
7 3 |
예제 출력1
10 4 21 2 1 |
내 제출
const fs = require("fs");
const inputData = fs.readFileSync("/dev/stdin").toString().split(" ");
var a = parseInt(inputData[0]);
var b = parseInt(inputData[1]);
console.log(a + b);
console.log(a - b);
console.log(a * b);
console.log(Math.floor(a / b));
console.log(a % b);
풀이
//4번째줄은 몫을 구해야 하니 나머지 값은 내림으로 계산
console.log(Math.floor(a / b));
'백준 > 입출력과 사칙연산' 카테고리의 다른 글
(node.js) 백준 18108번 : 1998년생인 내가 태국에서는 2541년생?! [Javascript] (0) | 2022.08.26 |
---|---|
(node.js) 백준 10926번 : ??! [Javascript] (0) | 2022.08.26 |
(node.js) 백준 1008번 : A/B [Javascript] (0) | 2022.08.26 |
(node.js) 백준 10998번 : A×B [Javascript] (0) | 2022.08.26 |
(node.js) 백준 1001번 : A-B [Javascript] (0) | 2022.08.26 |